SAP Knowledge Base Article - Public

2679238 - Not Able to Restrict E-mails Activity

Symptom

You have created a restriction to e-mails however the user have access to all e-mail activities.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activities work center.
  2. Go to the E-mails view.
  3. The user can see all the e-mails even with the restriction configured.

Cause

The user is assigned to a business role with administrator functions that bring additional authority and give access to all e-mails under activities.

Resolution

To restrict e-mails activities the user should not be assigned to administrator functions as Administrator and Data Protection and Privacy work centers.

To remove the work center that gives administrator authorization, perform the below steps:

  1. Go to the Administrator work center.
  2. Go to the General Settings view.
  3. Open the Business Users hyperlink.
  4. Search for the affected user.
  5. Select it.
  6. Press Edit -> Access Rights.
  7. Remove the work center that grants administrator role.

Keywords

Restrict; E-mails; Activities; Business Role , KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer add-ins all versions