Symptom
You would like to finish the invoicing for sales order from customer invoicing work center, however system shows an error message
Error - All Invoice Schedules must be invoiced or canceled to finish invoicing
Environment
SAP Business ByDesign
Reproducing the Issue
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Go to the Customer Invoicing work center
- Go to the Project Invoicing view and select Sales Order sub view
- Select the relevant Sales Order
- Select the relevant line item and select change status
- Select Finish Invoicing and error message appears
Cause
The invoice schedules must be in status either Invoiced or Canceled however the current invoice schedule status is Invoice Canceled. And this status is conflict with invoicing and hence the error message appears
Resolution
Please follow the below steps to fix the error;
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Go to the Sales Order work center
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Go to the Sales Orders view and select the relevant Sales Order
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Select Edit and navigate to Pricing and Invoicing
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Select the sub tab Invoice Schedule
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Select the relevant items with status Invoice Canceled
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Select the Cancel button and Save the Sales Order
- Go to the Customer Invoicing work center
- Go to the Project Invoicing and select Sales Order sub view
- Select the relevant Sales Order
- Select the relevant line item and select Change Status
- Select Finish Invoicing
Keywords
All Invoice Schedules must be invoiced or canceled to finish invoicing , KBA , all invoice schedules must be invoiced , AP-SLO , Sales Order Processing , Problem