Symptom
Visit cannot be located on the Map correctly, even though Check In and Check Out location are maintained.
If you try to change the Address in Visit, Address cannot be changed.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Visits Work Center.
- Go to Visits facet.
- Select "All Visits" and filter Visits with 'Completed' Status.
- Filter the 'Address' field as 'Sort Descending'
- Change to Map View.
- You should see the Visits come up on the Map.
Cause
Visit Map picks the location of the Visit from the Address field in Visit. Hence, Visits without Address maintained, will not show up in Visit Map View.
Users who are authorized to edit Account, would be able to change the account address.
Resolution
Visits to reflect on Map View, should have address maintained.
Map in Visits picks the location of the Visit, from the Address of the Account reflected in Visit.
If a visit is created after editing and saving the address for an account, then newly created visit would reflect the location on visit map with updated address.
Keywords
Visit Map, address, longitude, latitude, Map View, Check in, Check Out. , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem