Symptom
Email type "Business" is missing from the Email Type picklist selection:
Environment
Employee Central
Reproducing the Issue
1. Validate and check and the configuration for email-type picklist in Manage Business Configuration:
2. Validat and check ecEmailType legacy picklist:
3. Go to a user's contact information section, edit and select Email Type:
Cause
This is a permission (RBP) issue for the role of the user who's making the change.
Resolution
Please configure and enable Business Email Address View / Edit permission ideally for Employee Self Service or Basic User role if you allow users to edit or / and add their own email addressess onto their respective profiles.
See Also
Keywords
Business email type missing, ECT-103764, business picklist missing , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , Problem