Symptom
Users of the Cloud for Customer Outlook add-in perceives an issue with the add-in’s side panel, where in some cases it does not display the e-mail of the contact of e-mail’s main recipient (within the To field), but instead recognizes the CC e-mail recipient (CC is the name of the secondary recipients field, and it stands for Carbon Copy).
Environment
SAP Cloud For Customer / Sales
Reproducing the Issue
- Open the MS Outlook client.
- Select the Home ribbon.
- Select the Show Side Panel button under the SAP Hybris Cloud For Customer section.
- Go to the Sent folder.
- Select an affected e-mail.
- In the Side Panel, e-mail details will load.
You can see that the contact that is loaded is a CC’d recipient instead of the main recipient.
Cause
The side panel displays locally available contacts in the sent e-mail. First, it searches locally the contact to whom you sent the e-mail to, if that contact is not available locally then it searches for the next available contacts locally in CC. In this case, the To contact is not loaded to Outlook, that's why it is showing CC contact.
If no contact is available locally, the add-in then searches C4C to get the corresponding details of that contact.
Resolution
This is expected system behavior.
Keywords
Outlook, Contacts, CC, To, Side Panel. , KBA , LOD-CRM-GW-OUT , Outlook , LOD-CRM-CON , Contact , Problem