Symptom
When you are trying to save a Territory Rule the error message "Changes not allowed to this rule due to insufficient authorization'' is triggered.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Go to the Realignment Runs view.
- Select Territory Management Rules.
- Select the Add Row button.
- Select * to choose a value.
- Select the Save button.
- The error message "Changes not allowed to this rule due to insufficient authorization'' is triggered.
Cause
Within the Territory Management Rules, the Uploud and Download buttons are not visible. This means that the business user is not an Administrator user and thus rule maintenance is not allowed.
Resolution
For any user to be able to maintain territory rules, they need to have the Sales and Campaign Settings Work Center View assigned. The Upload and Download buttons will also then be visible.
Keywords
KBA , sales , territory management rules , realignment runs , download , uploud , changes not allowed , insufficient authorization' , LOD-CRM-TM , Territory Management , Problem