SAP Knowledge Base Article - Public

2681131 - Changes Not Allowed To This Rule Due to Insufficient Authorization

Symptom

When you are trying to save a Territory Rule the error message "Changes not allowed to this rule due to insufficient authorization'' is triggered.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Realignment Runs view.
  3. Select Territory Management Rules.
  4. Select the Add Row button.
  5. Select * to choose a value.
  6. Select the Save button.
  7. The error message "Changes not allowed to this rule due to insufficient authorization'' is triggered.

Cause

Within the Territory Management Rules, the Uploud and Download buttons are not visible. This means that the business user is not an Administrator user and thus rule maintenance is not allowed.

Resolution

For any user to be able to maintain territory rules, they need to have the Sales and Campaign Settings Work Center View assigned. The Upload and Download buttons will also then be visible.

Keywords

KBA , sales , territory management rules , uploud , changes not allowed , realignment runs , insufficient authorization' , download , LOD-CRM-TM , Territory Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions