SAP Knowledge Base Article - Public

2681136 - Unable to Change the Primary Contact in the Involved Party Facet

Symptom

You have added Involved Parties with Contacts in the Involved Parties facet in Opportunities and now you wish to change the primary contact. However the tick box is greyed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Opportunities view.
  3. Open any Opportunity.
  4. Go to the Involved Parties facet.
  5. Select an Involved Party.
  6. Click Edit.

Result: In the Contact, the Primary Contact tick box cannot be changed; the box is greyed out.

Cause

The Primary mark can only be changed in the Party Account directly.

Resolution

Please change the Primary mark in the party directly.

  1. Follow steps 1-5 as above.
  2. Click on the Involved Party name to open it.
  3. Go to the Contacts facet.
  4. In the column Main, tick the desired contact to make them the primary contact.

Keywords

opportunity, involved parties, contact, primary contact, main contact, c4c , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications all versions