Symptom
You have created some extension fields (KUT fields) with default value configured for the product facet on opportunities TI.
When you add a product from the Add button these default values are loaded, however when you add products from a list the default values are not loaded.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Steps to reproduce:
For example, you have created a KUT field named ABC:
- Go to Sales Workcenter.
- Go to Opportunities View.
- Open opportunity XYZ (where XYZ is the opportunity you want to edit).
- Go to Products facet.
- Click on Add button to a product. The default value for the field ABC will be loaded.
- Now, add a product using the product list. Click on the gear icon and select add from product list. The default value for the field ABC will not be loaded.
Cause
This is a system behavior.
Resolution
Default values only works when adding individual products.
If you need this functionality urgently you may contact your implementation manager to help with such request.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer
Keywords
KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem