Symptom
When a performance form is in the Completed step, ratings and comments left by users are not visible
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Performance Management
Reproducing the Issue
- Go to the performance inbox
- Open the in-process form
- Leave ratings, comments, etc...
- Send the form to the Completed step
- Return to the performance inbox
- Go to the 'Completed' folder
- Open the form
- Ratings/comments left by users are not visible
Cause
- Field permissions:
- Rating and comment fields have field permission type 'None' for all route steps, and 'Read'/'Write' permissions for selected steps only.
- When section or field permissions are set for route steps 'All', this includes the completed step:
2.Other's Rating Tab permission:
If there is no field permission type 'None' set for rating or comment fields, please check if 'None' is set for 'Route Steps: All' in General Settings > Advanced Settings > Other's Rating Tab Permission(s) defined.
Resolution
- To maintain permission type 'None' for all active steps in the form, but ensure ratings and comments are visible in the Completed step, change the 'Route Steps' selection from "All" to "Selected", and select all steps (cannot select Completed step).
- This will allow the 'None' permission to apply to all Modify or Signature steps in the form, but not to the Completed step:
- Notice in the screenshot below, when permission type 'None' is set to "All Selected", this permission no longer affects the Completed step:
See Also
Keywords
SF, Success Factors, PMGM, PM, GM, display, rating, comments, completed, form, missing. , KBA , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , Problem