SAP Knowledge Base Article - Public

2682218 - E-Mail Interaction Not Shown Within List View

Symptom

In a ticket, the e-mail interaction is not shown while using the List view functionality (Interactions tab) or in the Timeline facet.

Environment

SAP Cloud for Customer - Fiori Client

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket XXX (XXX represents the ticket ID).
  4. Go to the Interactions facet.
  5. Select the List view.
  6. Interaction is not shown.
  7. It is also missing in the Timeline facet.

Cause

The e-mail interaction is not shown, because the initial e-mail that created the ticket (the missing e-mail in the List view) contains inconsistent data.

While retrieving the interactions for the List view, a more stringent check for threaded interactions is being made and therefore the interaction is not coming up in the List view.

This typically happens when the ticket is created as a Follow-Up document instead of using the action 'Convert to New Ticket'.

This is available only if the e-mail comes in from one of the maintained e-mail channels.

Resolution

Make sure that you use the 'Convert to New Ticket' option.

You can also use the Grid view instead and here all interactions will be shown accordingly.

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket XXX (XXX represents the ticket ID).
  4. Go to the Interactions facet.
  5. Select the Grid view.
  6. All interactions will be shown.

Keywords

Interactions, Email, List view, Tickets, missing grid view, timeline , KBA , email , interaction , list view , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer core applications 1808