SAP Knowledge Base Article - Public

2682506 - Error "Please Configure Knowledge Base Mashup for Triggering Search" In Solution Center

Symptom

You receive an error message "Please configure Knowledge Base Mashup for triggering search" when you navigate to the Solution Center tab in a ticket.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ABC (ABC represents the ticket ID).
  4. Navigate to the Solution Center tab.
  5. Error message: "Please configure Knowledge Base Mashup for triggering search".

Cause

By default, Knowledge Base tab searches for the possible articles available based on the Product Description added in the ticket.

There could be two scenarios that trigger the error message:

  • Scenario 1: You want to use Knowledge Base in the ticket but configuration is incorrect.
  • Scenario 2: You do not want to use Knowledge Base in the ticket but Knowledge Base Pane is not removed in the Solution Center tab.

Resolution

  • For scenario 1: correct the configuration by creating a Knowledge Base Mashup in the system.

Refer help center document for more information: Solution Guide for SAP Service Cloud - Use Knowledge Base to Resolve Tickets.

  • For Scenario 2: remove the Knowledge Base Pane from Solution Center tab.

Steps to follow:

  1. Go to the Service work centre.
  2. Go to the Tickets view.
  3. Select Start Adaptation option.
  4. Open ticket ABC.
  5. Navigate to the Solution Center tab.
  6. Select the Knowledge Base pane.
  7. Untick (deselect) Set as Visible option.
  8. End Adaptation.

See Also

Help Portal document: Solution Guide for SAP Service Cloud - Use Knowledge Base to Resolve Tickets

Keywords

Knowledge Base, Solution Center, Error, Ticket, Search, Mashup, Configure, Solution , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-KB , Knowledge Base , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions