Symptom
You receive an error message "Please configure Knowledge Base Mashup for triggering search" when you navigate to the Solution Center tab in a ticket.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open ticket ABC (ABC represents the ticket ID).
- Navigate to the Solution Center tab.
- Error message: "Please configure Knowledge Base Mashup for triggering search".
Cause
By default, Knowledge Base tab searches for the possible articles available based on the Product Description added in the ticket.
There could be two scenarios that trigger the error message:
- Scenario 1: You want to use Knowledge Base in the ticket but configuration is incorrect.
- Scenario 2: You do not want to use Knowledge Base in the ticket but Knowledge Base Pane is not removed in the Solution Center tab.
Resolution
- For scenario 1: correct the configuration by creating a Knowledge Base Mashup in the system.
Refer help center document for more information: Solution Guide for SAP Service Cloud - Use Knowledge Base to Resolve Tickets.
- For Scenario 2: remove the Knowledge Base Pane from Solution Center tab.
Steps to follow:
- Go to the Service work centre.
- Go to the Tickets view.
- Select Start Adaptation option.
- Open ticket ABC.
- Navigate to the Solution Center tab.
- Select the Knowledge Base pane.
- Untick (deselect) Set as Visible option.
- End Adaptation.
See Also
Help Portal document: Solution Guide for SAP Service Cloud - Use Knowledge Base to Resolve Tickets
Keywords
Knowledge Base, Solution Center, Error, Ticket, Search, Mashup, Configure, Solution , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-KB , Knowledge Base , Problem