SAP Knowledge Base Article - Public

2682968 - Unable to add Business Role "SAP_BR..." to User

Symptom

You want to add a Business Role prefixed SAP_BR to a given user but cannot find the Business Role in the list of available Business Roles.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Go to Maintain Business Users app
  2. Open the user that you want to add the Business Role
  3. In Business Roles section, click on "Add" 
  4. In the popup, search for the role

Cause

The role prefixed "SAP_BR" is actually a Business Role Template.
Example: SAP_BR_GL_ACCOUNTANT_IN is a Business Role Template, not a Business Role

Resolution

To assign the Business Catalogs of a Business Role Template to a user, a new Business Role must be created using the template prefixed "SAP_BR". The resulting new Role can then be assigned to a user or users.

You can either check if there is any Business Role available that is already created from the template.

See Also

SAP Help Portal | How to Create a Business Role from a Template

SAP Help Portal | How to Maintain Business Users

Keywords

SAP_BR, Business, Role, not found, unavailable, missing, template , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions