Symptom
A Business Role prefixed SAP_BR needs to be added to a given user, but the Business Role cannot be found in the list of available Business Roles.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Maintain Business Users app
- Open the user that you want to add the Business Role
- In Business Roles section, click on "Add"
- In the popup, search for the role
Cause
The role prefixed "SAP_BR" is actually a Business Role Template.
Example: SAP_BR_GL_ACCOUNTANT_IN is a Business Role Template, not a Business Role
Resolution
To assign the Business Catalogs of a Business Role Template to a user, a new Business Role must be created using the template prefixed "SAP_BR." The resulting new Role can then be assigned to a user or users.
It is possible to check if there is any Business Role available that is already created from the template.
See Also
Keywords
SAP_BR, Business, Role, not found, unavailable, missing, template , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem