Symptom
The enum values for "classificationType" and "classificationTime" fields will now have validation for b1805
Environment
Successfactors Recruiting Management (RCM)
Reproducing the Issue
When accessing a requestion (approved or pre-approved), you can see that the eQuest classification type and classification time (field-type="enum") are not populating any values.
Cause
The allowable values for classificationType and classificationTime were in Uppercase
Resolution
In b1805, we introduced a validation check to ensure the classificationType and classificationTime enum values are valid. All Job Req templates that are not using the allowable values need to update their Job Req Template with the Uppercase values.
classificationType - PERMANENT, CONTRACT, CONTRACTPERMANENT and INTERN
classificationTime - FULLTIME and PARTTIME
The validation check was added in b1805 because it will provide us to support the option of removing one or more enum values from the selection list. For example, if we only want to have 3 classification types (PERMANENT, CONTRACT and INTERN), then the customer can leave out CONTRACTPERMANENT from the Job Req Template and classification type will only show 3 items instead of the default 4 items. In order to support the removal of an enum value, we need to determine which enum value is missing by comparing what is defined in the Job Req template against the valid allowable values.
See Also
2343086 - Configuring RCM integration with eQuest - Implementation tips and tricks
Keywords
eQuest Classification Type, eQuest Classification Time, classificationType, classificationTime, enum fields , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , LOD-SF-RCM-SCR , Software Changes, Services, Provisioning etc. , Product Enhancement