Symptom
Fields such as the 'zip-code' and 'city' are switched on in all address formats for the affected countries.
But do not appear under Configure People profile when configuring the Edit dialogue
Reproducing the Issue
1. Go to 'Configure People Profile'.
2. Scroll down to 'Address configuration'.
3. Select Edit.
4. Select the country.
5. See that some address fields are not displayed so cannot be edited.
Cause
1. If fields in SDM and CSF SDM for home Address have identical labels, the fields from CSF SDM are filtered out, not displayed. This is the reason why fields such as City and ZIP are not displaying for each country.
2. If you add new fields to CSF SDM these fields are not displayed in Configure PP3
Resolution
As a workaround to this issue it recommended to temporary rename the labels of CSF SDM fields or to rename the SDM fields (e.g. City2 , ZIP2 for each country your having the issue with).
Then remove the address block from Configure PP3, save, add the block again and save
Keywords
Configure people profile, address information, edit, not displaying , KBA , LOD-SF-EC-PP3 , People Profile (PP3) , Problem