Symptom
A query is visible in the mobile app, when in offline mode, however the same query has the Download checkbox unticked in Offline Sync Setup.
Environment
SAP Cloud for Customer/Sales/Service/Fiori
Reproducing the Issue
-
Log into the mobile app.
-
Open the dropdown by clicking the username in the top right of the screen.
- Click the Offline Settings button.
- Select the Default Queries facet or the My Saved Queries facet.
- Ensure that the checkbox in the 'Download' column is not checked for query ABC, workcenter DEF (ABC represents the name of the query; DEF represents the name of the workcenter).
- Click the Sync Now button.
- Wait for the sync to complete.
- Open the dropdown by clicking the username in the top right of the screen.
- Click the Go Offline button.
- Go to workcenter DEF.
- Check the available queries.
Query ABC is available in the dropdown list.
Cause
Offline sync settings only determine what data will be synced, not which queries appear in the query list.
Resolution
This is expected system behavior.
Keywords
Query, Offline, Custom, Download, Ticked, Checked, Visible, Query Visible, Query Available, Offline Sync Setup, Mobile, Sync. , KBA , AP-RC-MOB-OFL-SYN , Offline Data Synchronization , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions