Symptom
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
You have noticed that when you lunch the mobile application and search for one employee, you are able to see the phone information but in RBP you have restricted to not have access to it:
In Mobile the phone appears:
But in RBP you don't have permission to see it:
Environment
Employee Central Mobile Application
Reproducing the Issue
- Log in mobile application;
- Search for any employee;
- In the employee's profile the phone information is displayed;
- Now log in the instance and check for the RBP for the user logged in the APP;
- Go to Employee Data session in RBP;
- See that the fields are not permissioned;
Cause
Permission issue.
Although the fields are restricted in Employee Data session, if the same user has access to Employee Export for the target employee then this permission will be skipped.
Resolution
In order to have the phone restricted, the user using the App should not have permission to use the Employee Export for this user so you can do the following:
- Search for the rule which has the target user in the target population;
- In this role click in Permission > Manage User;
- Make sure that Employee Export is unchecked;
Keywords
Mobile Field level permission not respected in mobile , KBA , LOD-SF-EC-MOB , Employee Central Mobile , How To