SAP Knowledge Base Article - Public

2685936 - Attachment Under Ticket Interactions Has Changed The file extension to other format and cannot be opened

Symptom

Attachment Under Ticket Interactions Has Changed The file extension to other format and cannot be opened

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Center
  2. Go to Tickets view
  3. Open Ticket ABC(where ABC is Ticket ID).
  4. Navigate to Interactions and click on attachment
  5. Attahced file in .pdf format has changed to .exe (or any other file extension which can not be opened)

Cause

System checks the FileExtension is one among allowed FileExtensions of the specified MimeCode. If not, then it takes the FileExtension that is allowed for the specified MimeCode which has been marked as the default FileExtension for that MimeCode.

Resolution

You need to maintain the right FileExtension as the possible extensions for the MimeCode of the incoming e-mail.

Please follow the below steps to know how to check MimeCode of the e-mail

  1. Go to Administrator Work Center
  2. Go to General Settings view
  3. Open "Web Service Message Monitoring" under System Administration
  4. Select the Message ID of the inbound e-mail
  5. Click on View-> Payload
  6. Search for the HTML tag <MIMECode>XYZ</MIMECode>, XYZ represents MimeCode of the e-mail attachment
  7. Maintain the right FileExtension in XYZ MimeCode

Refer the help Portal link https://help.sap.com/viewer/abfba1342cfb4832ab722fa041f6c4b7/1808/en-US/349c653f5f164c2bb5b7af5ea7c19bf5.html for more information on MimeCode.

Keywords

exe, pdf, mime type, mime code, attachment, ticket, file extension , KBA , c4c , mime code , LOD-CRM-SRP-INT , Ticket Interactions , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions