Symptom
When you try to access admin tool "Manage Templates", an application error occurs.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Performance Management
Reproducing the Issue
- Go to Admin Center > Manage Templates
- An application error occurs
Cause
This is caused by the following two Performance Management permissions.
- General User Permission - Hide 'All active/inactive employees' option in Launch Forms wizard
- Manage Form Templates - Comprehensive template configuration for PMv12
When 'Comprehensive template configuration for PMv12' is granted to the permission role, the error won't occur.
When 'Comprehensive template configuration for PMv12' is not granted to the permission role, you need to select 'Hide 'All active/inactive employees' option in Launch Forms wizard'.
Resolution
Please review the user's permission via Admin Center > View User Permissions.
If the user doesn't have the permission 'Comprehensive template configuration for PMv12', please select the following permission for the relevant permission role.
- General User Permission - Hide 'All active/inactive employees' option in Launch Forms wizard
Keywords
Manage Templates, Role-based Permission, template.GetTemplateCount, Exception encountered while authorizing user for activity, 9ec54daa5160bcd502b6ab2d43acfd09ed3c302b , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-RCM , Recruiting Management , Problem