Symptom
When creating a Job Profile, and entering a text for description fields, receive error:
Field # in <language> is exceeding its max length
Environment
SAP SuccessFactors Job Profile Builder
Reproducing the Issue
- Log in to system
- Navigate to Admin Center > Manage Job Profile
- Locate a job profile and select the cog icon > Edit
- Make applicable changes > Next
- Select a section > make changes
- Select I'm done
- Receive error
OR
- Log in to system
- Navigate to Admin Center > Manage Job Profile
- Select Create Job Profile
- Make applicable selections > Next
- Select a section > make changes
- Select I'm done
- Receive error
Cause
The job profile content has exceeded the 4,000 bytes limit
Resolution
This is expected behavior as mentioned in Implementing and Managing Job Profile Builder - Text Limitation Errors When Creating Job Profile Content. The database cannot be adjusted to hold more than 4,000 bytes. The content will need to be adjusted to ensure the byte count is below the 4,000 limit.
Remove Extra Spaces
Place your cursor at the end of each sentence/statement in the text body fields to remove any extra spaces
Use a non-HTML based editor like Notepad to remove hidden HTML
- Copy the content from the job profile text body fields
- Paste the content into Notepad > Save the Notepad file
- From Notepad, reselect all the text and copy it
- Paste this plain text back into the job profile > Select I'm done
If the error still appears, check how many bytes are in the text body:
- Right click on the Notepad file that was saved > Select Properties
- Select the General tab > The Size field shows the byte count of the file
- Continue making adjustments until the count is below the 4,000-byte limit
See Also
Keywords
JPB, Character Limit, Job Description, limitation, locale, language, encode, special character, 4000 bytes, success factors, ssf, sfsf, errors, warnings, cannot save , KBA , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , Problem