Symptom
You have an account hierarchy set up where account A is parent of account B, which in turn is parent of account C. You wish to edit this hierarchy to put account C directly as child of account A, but find that to not be possible.
(In this document, accounts A, B and C represent the respective accounts in your system established in the same hierarchy.)
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Customers work center.
- Access the Accounts work center view.
- Search for account C.
- Open it.
- In the account's screen, click Edit.
- Click the value help for field Parent Account.
- Search for account A.
- The query will return no records.
Cause
This is the standard behavior of the hierarchy framework.
Resolution
To solve this, please do the following:
-
Edit account C.
- Remove account B from the Parent Account field.
- Save the changes.
- Now click Edit again.
- Click the value help for the Parent Account field.
- Search for account A.
- It will now be available for selection.
Note: If account A is still not found for selection in the Parent Account field after this, please check whether account A's status is not set as Obsolete.
Keywords
Account Hierarchy, Parent, Change , KBA , LOD-LE-BP-HIE , Business Partner Hierarchy , How To