SAP Knowledge Base Article - Public

2687235 - Cannot Change Assignment of Parent Account

Symptom

You have an account hierarchy set up where account A is parent of account B, which in turn is parent of account C. You wish to edit this hierarchy to put account C directly as child of account A, but find that to not be possible.

(In this document, accounts A, B and C represent the respective accounts in your system established in the same hierarchy.)

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Access the Accounts work center view.
  3. Search for account C.
  4. Open it.
  5. In the account's screen, click Edit.
  6. Click the value help for field Parent Account.
  7. Search for account A.
  8. The query will return no records.

Cause

This is the standard behavior of the hierarchy framework.

Resolution

To solve this, please do the following:

  1. Edit account C.
  2. Remove account B from the Parent Account field.
  3. Save the changes.
  4. Now click Edit again.
  5. Click the value help for the Parent Account field.
  6. Search for account A.
  7. It will now be available for selection.

Note: If account A is still not found for selection in the Parent Account field after this, please check whether account A's status is not set as Obsolete.

Keywords

Account Hierarchy, Parent, Change , KBA , LOD-LE-BP-HIE , Business Partner Hierarchy , How To

Product

SAP Cloud for Customer add-ins all versions