SAP Knowledge Base Article - Public

2687419 - Cannot search for an item within a library

Symptom

Item cannnot be found within the library search. Item is added in the library and library is available for the user.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning

Reproducing the Issue

Browse item in the user library search and no results found will appear.

Cause

  • The SKU associated to the item needs to be displayed in the library.
  • If the latest revision is not active and admin marked all older revisions to INACTIVE as well, this could cause 'Available in Library' set to NO unexpectedly.
  • Even admin re-activate the latest revision, it is still required to set  'Available in Library' to YES manually.
  • Refer to "See Also" section for other causes.

Resolution

  1. Check the SKU on the item record. If SKU is not showing, make sure to add this on the record configuration by going to System Administartion > Configuration > Entity Configuration > Item > Check Display checkbox for "Library SKU" >
  2. Finance > Master Inventory >
  3. Enter the SKU value from the item record > Edit >
  4. Enable "Available in Library:"

MasterInventory_Library.png

See Also

KBA 2827554 - Item Not Visible in Catalog Search Results in Learning

Keywords

sap, sf, lms, learning, search, cannot, find, display, item, SKU, library, not, show, master, inventory , KBA , LOD-SF-LMS-CAT , Catalog , LOD-SF-LMS-ITE , Items , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-USR , User Entity , Problem

Product

SAP SuccessFactors Learning all versions