SAP Knowledge Base Article - Public

2688908 - Access Restrictions Not Working for an Employee

Symptom

You have employee that has a set of access restrictions (granted from a business role, for example) but they do not seem to be effective.

Environment

SAP Cloud for Customer

Reproducing the Issue

For this document, we will use as example Accounts. Please note that this is applicable for any object in the system.

  1. Go to the Customers work center.
  2. Open the Accounts view.
  3. Select All in the search filter.

You will notice that the employee is seeing accounts that it is not supposed to see as per access restrictions defined.

Cause

The employee is an active delegate of other one. Delegate definition: "When you define an employee as your delegate, that person is granted the same access rights that you have for areas that you select".

Resolution

This is the system current standard behavior. You can alternatively end the delegate assignment by following the steps below:

  1. Go to the People work center.
  2. Open the Delegates view.
  3. Select Active Delegates in the search filter.
  4. Search for the employee you want to have the access restrictions working as previously defined.
  5. Click in the stop icon End Delegate Assignment in the Actions column.

Now the employee should have its access restrictions working as defined.

Keywords

Employee ; Delegate ; Access Restrictions ; Not Working ; Uneffective ; , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions