Symptom
You noticed that the Application Log is not displayed in the logged on user language.
Environment
SAP Business ByDesign
Reproducing the Issue
We will use the Invoice Block Execution Details as an example:
- Log on in the respective user language
- Go to the Service Orders work center.
- Select the Service Order Processing view.
- Open Service Order XYZ (XYZ represents the Service Order ID).
- Click on the View All button.
- Navigate to the Invoice Block Execution Details tab. (If this tab is not available you can add it via the personalization)
- Open the respective Application Log.
- In the section Description click on Expand.
- You can see that everything is displayed in another language than the users log on language.
Cause
The Application Log does not support translations. It is displayed in the language of the user who scheduled the respective run. Once the Application Log is written it cannot be changes anymore based on the users logon language. Real time translation is not supported as it can cause performance issues due to the large number of Application Logs.
Resolution
This is the current system behaviour.
Keywords
Application Log; Translation; Language , KBA , AP-RC-APL , Application Log , Problem