Symptom
SAP Cloud for Customer Outlook Add-in does not synchronize appointments created within the Outlook Calendar that are dated more than two weeks into the past.
Environment
SAP Cloud for Customer/ Sales / HTML5 / Fiori
Reproducing the Issue
-
Logon to the Outlook add-in.
- Click the New Items dropdown button.
- Select the New Appointment option.
- Date the appointment for greater than two weeks into the past.
- Click the Save and Close button.
Within the add-in's periodic synchronization to SAP Cloud for Customer, this appointment will not be added to the SAP Cloud for Customer tenant.
Cause
By current design, server-side integration synchronizes appointments from two weeks into the past, and 60 days into the future, dependent on the time of synchronization. If user’s mailbox was reinitialized, only appointments since re-initialization date will be synchronized to SAP Cloud for Customer and increases until the sliding period reaches 2 weeks.
Resolution
This is expected system behavior.
A workaround is to add an appointment to SAP Cloud for Customer manually by doing the following:
- Open the appointment within Outlook
- Under the SAP Cloud for Customer section in the Appointment ribbon, click the Add Appointment button.
This will manually synchronize the appointment to SAP Cloud for Customer.
Keywords
Outlook add-in, Appointments, Synchronization. , KBA , LOD-CRM-GW-OUT , Outlook , LOD-CRM-ACT , Activities , Product Enhancement