Symptom
- A new Welcome e-mail notification is triggered when an employee is rehired.
- When the termination record is deleted, the employee receives a new Welcome e-mail.
Reproducing the Issue
Scenario 1:
-
Standard rehire process for an employee that has been terminated in the past.
Scenario 2:
- Check an employee whose status is Terminated.
- Go to the employee's My Employee File
- Under section Job Information, open Change History window.
- Check for the Termination record and delete it.
(We do not recommend performing this scenario as it leads into data inconsistencies)
Cause
Welcome e-mail is triggered to any user that is activated or reactivated (new status input is Active).
Resolution
This is the system's expected behaviour. The system will trigger a welcome e-mail to any user that is activated or reactivated.
Please note that the standard process in a business situation is to rehire the employee, that is, to create a new hiring event, rather than to delete it's previous termination record.
Keywords
SuccessFactors, Success Factors, Welcome e-mail, Email notification, E-mail notification, Rehired, multiple notifications. , KBA , LOD-SF-PLT-NOT , Email Notifications , Problem