SAP Knowledge Base Article - Public

2691158 - Survey with Mandatory Field Can Be Submitted without Data Filled in

Symptom

You have a survey with category "Product", and mandatory fields (questions) configured.

When the survey is assigned to a visit/ticket,  you find that the survey can be submitted directly even if no data is filled.

You are wondering why the survey can be submitted even if without filling the mandatory fields in it.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: you created  a survey 123 (123 represents the survey ID) with category "Product", and mandatory fields (questions) configured. The survey gets routed to our example visit.

  1. Go to the Visits work centre view.
  2. Open Visit ABC (ABC represents the visit ID).
  3. Go to the Surveys facet and edit the survey 123.
  4. In the opened survey page, click Submit without filling in any data.
  5. The survey can be submitted and it's status is now Completed.

Cause

For a survey which Category "Product", for a product in it, if NO questions are answered, the mandatory check will be skipped: assuming that the user does not want to answer questions for that product. If ONE question is answered, the mandatory check will work as expected and the user is not able to submit the survey.

It's possible that there is more than one product in a Survey and the user wants to fill the survey only for some products. For products where he does not want to fill even one answer, the user is allowed to do that and even if a field is mandatory for the product, it will not be checked.

Due to this logic, the system skips mandatory checking for the survey if there are several products in it. The user can submit it. However, if even one field is filled, the mandatory check will work. For the survey with only one product, the mandatory check cannot be skipped.

There could be multiple valuations [products, comp products etc.] in a given survey. At field level, the sales rep doesn't take responses for every valuation which could be ranging from 10-1000.

All Mandatory checks are only run when a respective valuation is answered. Otherwise the system cannot accept the survey submission. This makes a practical deadlock.

Resolution

This is current system standard behavior.

Keywords

Survey, Mandatory field, Submit, Product , KBA , LOD-LE-SUR , Survey , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions