SAP Knowledge Base Article - Public

2691388 - System Triggers the Error Message 'Action PGR_BACKGROUND not possible; action is disabled' When Doing Post Goods Receipt with Custom Solution

Symptom

You have created a Partner solution with a Custom User Interface to perform Post Goods Receipt as Planned for Stock Transfer Orders. However, when you try to execute the action, the system returns the error message  'Action PGR_BACKGROUND not possible; action is disabled'. Now you want to know how to resolve the issue.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the relevant Custom work center.
  2. Go to the relevant Custom work center view.
  3. Enter a valid value in the Field 'Stock Transfer Order ID'.
  4. Click the Save button.
  5. System returns the error message: Action PGR_BACKGROUND not possible; action is disabled.

Cause

Post Goods Receipt is not possible if the Status of the Inbound Delivery Notification is not Received.

Resolution

1. Set the Inbound Delivery Notification to Received status. The Action:ACKNOWLEDGE_DEL_NOTE at the Root of 'APDL_INBOUND_DELIVERY.Action' is already released.

2. Once the Inbound Delivery Notification is in Received status, the Action PGR_BACKGROUND at the Root of 'APDL_INBOUND_DELIVERY' shall be enabled for consistent Inbound Delivery Notifications only.

Keywords

Post, Goods, Receipt, as, Planned, Action, PGR_BACKGROUND, not possible, action, is, disabled, PDI , KBA , AP-IDP-ID , Inbound Delivery , Problem

Product

SAP Business ByDesign all versions