SAP Knowledge Base Article - Public

2691981 - Home Page Custom Tiles are not Showing the Titles and Labels for Different Languages

Symptom

When you create custom tiles in Fiori Home Screen in the language A (for example English) and login in the system in the language B (for example in Spanish) the tiles label will appears as blank, without any translation.

Environment

SAP Cloud for Customer

Cause

You should maintain the translation for the Tiles Label directly in the desired language.

Resolution

To proceed with the translation, follow the steps below:

  1. As a Key User, login to C4C system in the desired language which you want to create the translation.
  2. In home screen, click on the pencil icon to adapt the screen (either top or bottom right of the screen, depending on your system settings).
  3. Select the business role where the tile was added, e.g. default.
  4. Click on the tile for which the title is not showing up.
  5. Add the title and description in the new language.
  6. Save, Close and publish the changes done.
  7. Now the tile should display the translation. 

Keywords

home page, custom tiles, title, translation description , KBA , LOD-CRM-HOM , Home Page , AP-RC-UIF , C4C UI Framework , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions