SAP Knowledge Base Article - Public

2692767 - Notes from Last Visit and Last Visit Date/Time Values are not Visible

Symptom

Values for the fields Notes from Last Visit and

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login with User t1 (Where t1 is the user ID) assigned to Sales Organisation 1000 (Where 1000 is the Sales Organisation ID)
  2. Go to Visits Workcenter and Navigate to Visits View.
  3. Click on New button.
  4. Enter the  Account DEF(Where DEF is the Account ID) which has existing Completed Visits and No Sales Data maintained.
  5. Save and Open the Visit.
  6. Add some Notes in the Notes field.
  7. Check In to the Visit.
  8. Check out so that the Visit Status is completed. 
  9. Login with User t2 (Where t2 is the user ID) assigned to Sales Organisation 1111 (Where 1111 is the Sales Organisation ID).
  10. Ensure that the User t2 has Access restrictions for the Visits based on Sales Organisation.
  11. Follow the steps (2 to 5) to Create another Visit for the same Account.
  12. You will see that the fields Notes from Last Visit and Last Visit Date/Time are empty.

Cause

This is because of the Access restriction imposed on the User for other Visits. If the User does not have access to existing completed Visits of the same Account, then the Notes from Last Visit and Last Visit Date/Time will not be Visible for the user.

Resolution

The  dependency on the visibilty of Notes from Last Visit and Last Visit Date/Time Values based on the User's access for the previous completed Visit is a standard system behavior.

Keywords

Notes from Last Visit,Last Visit Date/Time , KBA , notes from last visit , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions