SAP Knowledge Base Article - Public

2693255 - SAP Analytics Cloud (SAC) Mobile app is not sending any client certificate for live connections.

Symptom

  • The SAP Analytics Cloud (SAC) Mobile App has been set up with the client certificate imported (mcert). This certificate is used only for backend live access to database connections such as HANA.
  • Authentication towards the database works in the browser when the authentication option for the connection is set as "No Authentication", but affects the mobile app only.
  • An SAC custom SAML IdP is used but no client certificate is present.
  • The app is not sending any client certificate for live connections.

Environment

  • SAP Analytics Cloud
  • SAP Analytics Cloud Mobile App for iOS
  • Live Data Connection

Reproducing the Issue

  1. Import client certificate on the SAC Mobile app
  2. Create a connection with No Authentication.
  3. Consume that connection on the mobile app.

Cause

The SAC Mobile application does not support "None" as an authentication option.

Resolution

Change the authentication option to SAML SSO.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem

Product

SAP Analytics Cloud 1.0