Symptom
E-Verify activity received an 'Asynchronous task is completed with error.' message when case status of E-Verify is under DHS TNC Forms Unsigned.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Navigate to SAP SuccessFactors HCM > Onboarding > E-Verify Activity of Candidate
- When opening the activity the error message shows: 'Asynchronous task is completed with error.'
Cause
The reason for this error varies from time to time and due to non-sync in the status of the activity in both Department of Homeland Security and SAP SuccessFactors Onboarding.
The following are common error tags or messages found in the logs of affected new hires:
- EVerifyReferTNCRetrieveRDCAsyncTask
- An error occurred while executing the task.
- Error Code 00-00033
- Invalid case state for current operation
- ErrorCode is FormFileNotExists
Resolution
For Live Customer(s)
This is a known issue and can only be resolved with intervention of SAP Cloud Product Support. When you encounter this behavior, please reach out to SAP SuccessFactors Cloud Product Support in SAP for Me via SAP Expert Chat or Support case and we will check the record of new hire directly in E-Verify database. In addition, follow the template when creating an case and provide the needed information below.
- Subject: KBA 2693406 - Asynchronous Task is Completed with Error (DHS TNC Forms Unsigned]
- Component: LOD-SF-OBD-EVF
- Problem Description:
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See Also
Keywords
OBD, ONB, LOD-SF-OBD, e-Verify, Everify, E-Verify, DHS, United States Department of Homeland Security, United States Citizenship and Immigration Services, USA, United States of America, Verification, Verify, Employment, I-9, I9, SSA, Social Security Administration, Authorized, Work, DHS Tentative Nonconfirmation (TNC), ONB-20066, Error Code [00-00033] , KBA , #sfobdeverify , #sfobdneedtopublished , #sfobdproblem , #sfobdissue , LOD-SF-OBD-EVF , e-Verify , Problem