Symptom
Workflow is visible under manage pending workflow request with processor, but processor cannot see workflow in his/her Todo action item.
Environment
Successfactor Employee Center: Workflow Managment
Cause
This issue may be faced if in your workflow configuration "No Approver Behavior" has been configured as a stop workflow and position object has been used as an approver.
If this position is vancant, the workflow will be not assigned to any processor. Once you assign responsible person to this position, system will reassign the workflow to the newly assigned person, but person will see no approval item in pending request screen.
Resolution
This is expected behavior of the system. To do list is static and it only gets updated if workflow request is changed or updated.
Workaround:
User can go to "View My Pending Request" and approve the workflow from there.
Admin can update processor one more time under "Manage workflow Request" and then the user will be able to see approval item in Todo action item.
Keywords
Pending request, ToDo, approver, missing , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem