SAP Knowledge Base Article - Public

2694226 - Global Search is Not Working When Searched With Email Address

Symptom

Global Search is Not Working When Searched With Email Address

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the view Global Search on top right corner.
  2. Choose the Category E-Mails.
  3. Enter the email address example@example.com into search bar.
  4. Choose the button Enter.
  5. Observe that Email XYZ (XYZ represent email id) is not shown in search results.

Cause

It is an existing system behavior. Global Search for email doesn't search on email address but rather by using Description or Party names.

Resolution

Global Search for email doesn't search on email address but rather by using Description or Party names.

If the email address is part of these names then it will be found and one may think it was the actual address. For example a search by " example@example.com" will return emails like DEF  (DEF represents email id)that have the description "Action-Required: Office 365 Email Protection( example@example.com)". this was returned because the address is part of the description. In case of searching by " example@example.com" it doesn't find any email having that string in description or some Party name.

Another example is if you search with example2@example.com  it will find email example because the customer name is "Example2".

*example2 represents the name of customer and example2@example.com represents email id.

Keywords

Email search, global search with email id   , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins 1808