Symptom
View User Permission is blank / empty.
Environment
SuccessFactors BizX Foundations
Reproducing the Issue
Go to "View User Permission" page under Admin Center, the page is blank and no field is present to be searched by the users:
Cause
1. This issue may be caused by the Job code element label not being defined in the Data Model.
2. This is caused by missing labels for the field in the Data Model.
Resolution
To complete tasks in Provisioning, please contact your Implementation Partner. If you are no longer working with an Implementation Partner, contact SAP Cloud Support (Component LOD-SF-PLT) to review the Data Model and add the Job code, in case it is not listed there yet.
SAP Cloud Support & Partners Only:
SOLUTION for Case #1: Issue caused by the Job code element label not being defined in the Data Model
Configure the label accordingly in the Data Model:
<standard-element id="jobCode" required="false" matrix-filter="false">
<label>Job Code</label>
</standard-element>
SOLUTION for Case #2: Issue caused by missing labels for the fields depending on the locale enabled for the customer's instance.
See sample below for a customer's instance where "en_US" [English US] is enabled.
WRONG CONFIGURATION:
<standard-element id="username" max-length="100" required="true" matrix-filter="false">
</standard-element>
CORRECT CONFIGURATION:
<standard-element id="username" max-length="100" required="true" matrix-filter="false">
<label xml:lang="en-US">Username</label>
</standard-element>
See Also
Keywords
view user permission blank empty bizx admin center , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-PLT-RBP , Role Based Permissions , Problem