Symptom
-
SSO is not working when viewing stories in SAP Analytics Cloud Mobile App. User is getting prompted for login again for connection.
Environment
- SAP Analytics Cloud 2018.16.3
- SAP Analytics Cloud Mobile App 2.28.0
Reproducing the Issue
- Add story using Live Data connection to Hana in SAP Analytics Cloud, using SSO and SAML authentication
- Ensure that the story works fine on Desktop browser
- Launch Analytics Cloud Mobile and enter server URL and credentials
- List of stories is displayed
- Select story using the Live Data connection to Hana
- Prompt to login pops up.
Cause
SAC Mobile app is a native app which SAML Token is not able to consume in mobile device. Therefore, it doesn't support SSO without certificate.
Resolution
If your IDP support X509 certificate, you can leverage and import to the device by following the help document in https://help.sap.com/doc/00f68c2e08b941f081002fd3691d86a7/release/en-US/9946e4a060f9431f956ae82e34f4c112.html
See Also
- How to find User Assistance for SAP Analytics Cloud?
- Ask a question on the SAP Community!
- 2487011 - What information do I need to provide when opening incidents with SAP Analytics Cloud (Hint: Use component LOD-ANA*)
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Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , sac authentication pop-up kba , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem