Symptom
You are replicating business partners from CRM to Cloud for Customer (C4C) and the messages fail in Web Service Message Monitoring with the following error: Solve Configuration Issue in Code List Mapping for field PersonNameFormatCode with value XXX, where XXX is a user defined value for the field NameFormatCode in the incoming message.
Environment
SAP Cloud for Customer
Reproducing the Issue
After replicating the business partners:
- Go to the Administrator work center.
- Click on the Web Service Message Monitoring link in the General Settings view.
- Observe the failed messages with interface BusinessPartnerReplicationIn. The following error message is displayed in the Error Text column: "Solve Configuration Issue in Code List Mapping for field PersonNameFormatCode with value XXX".
Cause
The PersonNameFormatCode is Country specific, consequently setting Country as the local context in the Code list mapping is required.
Resolution
-
Open the Business Configuration work center.
- Open the 'Code List Mapping for Integration with External Applications' activity.
- Click the 'Maintain Code List Mapping' link.
- Select the PersonNameFormatCode local data type.
- Add a Code List Mapping Rule for each local context / country you require, using 'Map Individual Codes'.
- Add the values you have in your on prem system as the external code against A1 in the local code.
- Maintain one entry as the Outbound default per local context.
Keywords
KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To
Product
SAP Cloud for Customer add-ins all versions