SAP Knowledge Base Article - Public

2696016 - How to join the data sources Activity BTD Reference and Survey Answers

Symptom

You want to report on phone calls tasks and surveys (worklist items) as it is available for visits for example but there is no standard data source available which can be used in reporting.

Environment

SAP Cloud for Customer

Cause

As there was no data source available our developers created a new one. The Activity BTD Reference data source (technical ID CODACTBTDB).

Resolution

The Activity Business Transaction Document Reference data source is available with 1811. This data source can provide links to other data sources in C4C which are referenced to any activity. In this scenario to the data source Survey Answer.

  1. Go to the Work Center Business Analytics, View Design Data Sources.
  2. Click New and Joined Data Source.
  3. Enter a name for the new data source, a description if you like and choose the type as left outer join.
  4. Click Add Data Source and select data source Activity BTD Reference (technical ID CODACTBTDB).
  5. Select the characteristics which you want to have and add them to your new data source.
  6. Following characteristics are mandatory to create joins and filter across activity types:
    - Under Dimension Activity select the characteristics Activity Type and Category.
    - Under Dimension Document References select the characteristics BTD Reference, BTD Reference ID, BTD Reference Item, BTD Reference Type and BTD Reference Role Code.
  7. Click Add Data Source and select data source Survey Answers (technical ID FNDQREVQVB).
  8. Select the characteristics and key figures you would like to have in your new joined data source.
  9. Following characteristics are mandatory to create joins and filter for activity survey answers.
    - Under Dimension Survey select the characteristics Document Type, Document UUID, Survey ID (if joining to retrieve information for all surveys maintained in activities) and Valuation Collection UUID (if joining to retrieve information for surveys which have responses maintained only).
  10. Based on your companies business requirements, you can choose to bind the data sources using the characteristics Survey ID or Valuation Collection UUID.
  11. Save your newly created data source in order to create a new customized report on top of it. Assistance for modeling data sources and reports can be found here.

See Also

If you create a customized report the following characteristics need to have either a fixed or variable based value selection maintained in the Report Wizard Step 4 Characteristic Properties:
- Activity Type: 86 (Phone Call)
- BTD Reference Type: 1876 (Survey)
- Document Type (Survey): 86 (Phone Call)

Note: If the intention for you is to report on surveys for a specific activity type, fixed value selections are recommended. If you want to reuse the same report for analyzing surveys for all supported activity types (visit and phone call), you can just maintain BTD Reference Type as fixed value and enter the activity type during report usage.

If you want to analyse and report on visits/phone calls tasks and surveys, you can also join the Activity BTD Reference data source with the Activity Task data source (technical ID CODTKAHB). For the custom report the following characteristics need to have either a fixed or variable based value selection maintained:
- Activity Type: 86 (Phone Call)
- BTD Reference Type: 542 (Task)

Note: When reporting on tasks for phone calls/visits, if you want to report on tasks which are created as part of the tasks for that object and not as follow-up tasks for that object, use the characteristic Follow up Task Indicator to filter tasks accordingly, X = follow up task, # = Phone Call/Visit worklist task.

Keywords

Activities, Survey, data sources, business transaction document, CODACTBTDB, FNDQREVQVB , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-ACT , Activities , LOD-LE-AM-ANA , Activity Analytics , How To

Product

SAP Cloud for Customer add-ins 1811 ; SAP Cloud for Customer add-ins 1902