SAP Knowledge Base Article - Public

2696075 - Cannot Add a Survey to a Ticket

Symptom

You are not able to add survey to a ticket when you select survey and click ok, the survey is not getting added to ticket.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the work center Service.
  2. Choose the view Tickets.
  3. Search XYZ (XYZ represents ticket id).
  4. Open the Ticket.
  5. Choose Survey Tab.
  6. Choose the button Add.
  7. Choose the survey DEF (DEF represents survey name).
  8. Choose button OK.
  9. Chosen Survey is not Added to the ticket.

Cause

The survey which you are trying to add in ticket XYZ has survey category as Others or Satisfaction.

Note: There are two kinds of Surveys External Surveys and Internal Surveys. Only Internal Surveys can be added to Ticket so that employees who have access rights for the system can login and fill up the Surveys.

Resolution

The only way to send External Surveys in Ticket is via Workflow Email.

  1. Go to the Business configuration work center.
  2. Choose the view Implementation Project.
  3. Choose the project XYZ (XYZ represent project name).
  4. Choose the button Open Activity List.
  5. Choose the Fine-Tune tab.
  6. In the Search filed enter Survey.
  7. Open the Activity.
  8. Choose the view Maintain Survey Categories.
  9. Create a survey category, e.g. “Customer Satisfaction”, of type Satisfaction.
  10. Create a survey of category “Customer satisfaction”.
  11. Take note of the Survey ID.
  12. Create a workflow rule of type Email.
  13. Define the condition (on save or scheduled) so that the email is sent when you prefer. e.g. 3 days after the ticket is completed.
  14. Create an HTML email template, with a placeholder with the format #SURVEYID# e.g. #SURVEYXX#, if the ID of the customer satisfaction survey was XX.
  15. In the placeholder mapping, map #SURVEYXX# to anything, it does not matter e.g. to “Ticket ID”.
  16. The code will recognize the placeholder and replace it with a link.
  17. When the email is sent, the system will Create an instance of the survey.
  18. Generate the External link.
  19. Use it to replace the placeholder.

Note: It only works for Email, not for Notifications.

 

 

Keywords

External survey, Survey, Ticket survey , KBA , LOD-LE-SUR-DEF , Survey definition = design time , Problem

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811