Symptom
The Role field is not available to select as a code to restrict for the Sales Data business object
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center.
- Go to the Code list restrictions.
- Select the New button.
- In the business object field, select sales data.
- Select the Code to Restrict drop down field.
- Choose Customer Group.
- Open the Business Field OVS.
- The Role field is not available here to restrict as a business field.
Cause
This is the expected system behaviour.
This cannot be supported as the Code to Restrict field Customer Group ( field on which CLR is intended to be created ) is in BusinessObject / BusinessContext Sales Data and the other control field Role is in BusinessObject / BusinessContext Customer. CLR feature works within a business objects only.
This behavior is the same for all fields from Sales Data business object.
Resolution
As a workaround you may take help from partners and using PDI SDK create an extension field with same data type as Role and value populate with same value as Customers->Role. Then you can use this newly created extension field for CLR. ( this has to be evaluated by your partner if any ). There is solution using KUT.
Keywords
Code List Restriction, Field not available CLR; advanced search code list restriction , KBA , code to restrict , sales data , role , customer group , restrictions , business field , LOD-CRM-ACC , Account , LOD-LE-RC-CLR , Code List Restriction , How To