Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
For a ticket created via e-mail, the original e-mail is attached in the ticket with name "OriginalContent.html". This attachment does not render special characters correctly (for example German characters ä, ß)
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Go to the Tickets view.
- Open ticket 123 (123 represents the ticket ID).
- Go to the Attachments facet.
- Open the attachment named "OriginalContent.html".
Or
- Go to the Service work center.
- Go to the Tickets view.
- Open ticket 123 (123 represents the ticket ID).
- Go to the Interactions facet.
- Select the interaction > Click in Actions > View Original Content.
In both cases, new window will be opened, showing the content with wrong characters.
Cause
The documents are always encoded using UTF-8 charset. The handling for encoding using the charset passed as part of the meta tag is currently not available.
Resolution
This is as system current limitation. The functionality is planned to be enhanced and at this point in time, we are not in a position to provide more accurate information on date and/or timelines for this.
Keywords
e-mail, email, ticket, special character, interaction, alphabet , KBA , AP-RC-OUT , Output Management , How To