SAP Knowledge Base Article - Public

2696623 - Field "Out of Range Check-In" Showed as No in Visit.

Symptom

When you click the “Check in” button in Visit, the field “Out of Range Check-In” displays 'No' even though the current position is far more than the distance setting in Business Configuration.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visits work center.
  2. Open the Visit ABC (where ABC represents the Visit ID).
  3. Press the "Check in" button in the Bottom menu bar.
  4. Find the field “Out of Range Check-In” showed as 'No'.

Cause

Geo Codes are missing at Account master data level OR geolocation services are not enabled in your mobile device.

Resolution

To maintain geo codes in accounts:

  1. Go to the Customer work center.
  2. Go to the Account work center view.
  3. Search for the Account of Visit ABC.
  4. Go to the Addresses Facet.
  5. Go to the Details Pane.
  6. Maintain the Latitude and Longitude field accordingly. There are 2 fields named as Latitude and Longitude, which you can use Edit Master Layout to add.

To turn on geolocation services in your mobile device.

  1. Seek the reference manual of your device manufacturer to see how you turn on the geolocation services.

Keywords

Out of Range Check-In; Visit ; Geolocation ; Geo Location ; geo location ; check in ; check-in; , KBA , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions