Symptom
Manager did not recieve a workflow for time off request, although it is still showing as "Pending" for user.
In the Manage Data > Employee time > Workflow Request is -1.
When trying to cancel this request to retrigger the workflow, it will show the error "Workflow ID not found or not valid".
Environment
Employee Central, Time Off
Cause
There is a configuration Issue.
There is a take rule assigned to the time type which triggers a workflow.
Take rules are only meant for validations and you cannot set a field / trigger a workflow using a take rule.
A workflow should be triggered in Configure Object defintion > Employee Time > under Save rules.
As the configuration was not correct, the workflow Request on the Employee Times was set -1, and that is the reason the workflow is not found for this request.
Resolution
Remove the rule from the time type, and assign as save rule on employee time object
Cancel time off request via time off UI, and retrigger the workflow.
Keywords
Workflow request ID, time off request stuck in pending status, no workflow triggered, TIM-3338 , KBA , LOD-SF-EC-TIM , Time Off , Problem