Symptom
The time account type eligibility status is not updating when an employee is moved to a global assignment.
Environment
Successfactors - Employee Central Time off
Reproducing the Issue
- Set up global assignment for an employee
- The Time Account Type Eligibility Status (Manage Data) is not getting updated.
Cause
Time Off information is not considered by the Global Assignment feature. It is a limitaion currently.
Resolution
Current Behavior
For now, Time Off information is not considered by the Global Assignment feature. Therefore, no Time Accounts and Eligibility statuses are created for the new user when setting up or editing a Global Assignment. Only editing the Job Information or its history for the user leads to actions for Time Off (creating and adapting Accounts and Eligibility status).
Workaround
- The Time Off Information can be assigned for the new user after creating the Global Assignment. Changes like shifting the end date for the Global Assignment should be done via JobInfo change and not via editing the Global Assignment information directly.
- There is an enhancement already to enhance the behaviour of time off during global assignment TIM-552 with no date to be released yet.
Keywords
Time off Time Account Type Eligibility Status Eligibility Status Global Assignment TIM-552 , KBA , LOD-SF-EC-TIM , Time Off , Problem