Symptom
Comments do not appear in emails if a workflow request is sent back to the initiator when using the standard email templates
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
Employee Central - Workflow & Trigger (Rules & XML)
Reproducing the Issue
- Initiate a workflow request
- Proxy as the approver
- Access the workflow and post some comments
- Send Back the workflow request
- Comments section in the email is empty
Cause
Comments sent using the Post button update the workflow activity section. When sending a comment back to the initator, type out your comment and use the 'Send Back' button, do not 'Post' the comments
Resolution
When trying to leave a comment, do not use the 'Post' button unless you would like to update the workflow activity.
Using the 'Send Back' button will send the comments back to the initator of the workflow
Keywords
workflow, request, comments, send back, initiator, approver, SENTBACK_BY_COMMENT, email, standard, template , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem