SAP Knowledge Base Article - Public

2697907 - Send Back Workflow Notification Comments not Appearing in Emails

Symptom

Comments do not appear in emails if a workflow request is sent back to the initiator when using the standard email templates

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

Employee Central - Workflow & Trigger (Rules & XML)

Reproducing the Issue

  1. Initiate a workflow request
  2. Proxy as the approver
  3. Access the workflow and post some comments
  4. Send Back the workflow request
  5. Comments section in the email is empty

NoComments.png

Cause

Comments sent using the Post button update the workflow activity section. When sending a comment back to the initator, type out your comment and use the 'Send Back' button, do not 'Post' the comments

Resolution

When trying to leave a comment, do not use the 'Post' button unless you would like to update the workflow activity.

LeaveComments.png

Using the 'Send Back' button will send the comments back to the initator of the workflow

Comments.png

Keywords

workflow, request, comments, send back, initiator, approver, SENTBACK_BY_COMMENT, email, standard, template , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem

Product

SAP SuccessFactors Employee Central all versions