Symptom
When trying to view the eligibility section in a compensation template, all you can see is a blank screen and the following error: "An application error occurred. Please try again later, or notify support..."
Environment
SAP SuccessFactors Compensation
Reproducing the Issue
Go to:
- Admin Centre
- Compensation Home
- Select Template
- Plan Details
- Eligibility
Cause
The most common cause is that the last user who modified the eligibility cannot be found by the system
Resolution
A) If the user no longer exists you can:
- Create the user again with user import. Now you should be able to see the eligibility screen.
- Login with any user, update all the rules associated with the template.
- Remove the user created in step 1 if necessary.
B) If the user still exists you can:
- Simply re-activate the user who made the previous changes to the eligibility. Once you do this then you will be able to access the page again.
- Make sure to use another user to modify the eligibility and then you can de-activate the previous user if you wish.
C) If this is not the cause then you should open a case with support. We will then be able to use our resources to find why the error has been caused.
For Support:
- See internal Memo for instructions on how to troubleshoot this issue
Keywords
Error, Eligibility, Template, Tab, NullPointerException, lastModifiedUserBean, null object, Rules , KBA , LOD-SF-CMP-ADM , Admin Tools, Settings, Permissions , Problem