SAP Knowledge Base Article - Public

2698582 - Error when trying to view the Eligibility Screen in the Compensation Template

Symptom

When trying to view the eligibility section in a compensation template, all you can see is a blank screen and the following error: "An application error occurred. Please try again later, or notify support..."

Environment

SAP SuccessFactors Compensation

Reproducing the Issue

Go to:

  1. Admin Centre
  2. Compensation Home
  3. Select Template
  4. Plan Details 
  5. Eligibility

Cause

The most common cause is that the last user who modified the eligibility cannot be found by the system

Resolution

A) If the user no longer exists you can:

  1. Create the user again with user import. Now you should be able to see the eligibility screen. 
  2. Login with any user, update all the rules associated with the template. 
  3. Remove the user created in step 1 if necessary.

B) If the user still exists you can:

  1. Simply re-activate the user who made the previous changes to the eligibility. Once you do this then you will be able to access the page again.
  2. Make sure to use another user to modify the eligibility and then you can de-activate the previous user if you wish.

C) If this is not the cause then you should open a case with support. We will then be able to use our resources to find why the error has been caused.

For Support:

  • See internal Memo for instructions on how to troubleshoot this issue

Keywords

Error, Eligibility, Template, Tab, NullPointerException, lastModifiedUserBean, null object, Rules , KBA , LOD-SF-CMP-ADM , Admin Tools, Settings, Permissions , Problem

Product

SAP SuccessFactors Compensation all versions