SAP Knowledge Base Article - Public

2698759 - Employees added as Custom Parties a Visit are able to see the Visit in their Calendar

Symptom

Employees added to the Visit as Custom Party roles are able to see the Visit in their Calendar though they are not the Organizer or Attendee of the Visit.

Environment

SAP Cloud for Customer

Reproducing the Issue

Suppose you have custom party roles in Visits.

  1. Go to Visits Workcenter.
  2. Create a new Visit from the Visits view.
  3. Enter the Account XYZ (XYZ reresents the Account ID)
  4. Make Employee 01(01 represents the Employee ID) as the Organizer and Attendee of the Visit.
  5. Navigate to Other parties facet.
  6. Click on the add button and Add Employee 02(02 represents the Employee ID) as a Custom Party role.
  7. Save the Visit.
  8. Login with the user of Employee 02 .
  9. Open the Calendar.
  10. Set the day as Today.

You will see that the Visit is visible in the calendar though the Employee is a custom party in the Visit.

Cause

Employees will be able to see the Visits in their calendar as long as they are associated with the respective Visit irrespective of their Party roles. Visibility of the Visit in the calendar is not limited only to  the Organizer and the Attendees.

Resolution

Employees who are added as Custom Parties to a Visit will also see the Visit in their calendar and this is a standard system behavior.

Keywords

Visit, Calendar, Custom Party Role , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions