Symptom
You have set Approval as mandatory for the Opportunity BO. However, the Opportunity can be Set to Won or Set to Lost without the mandatory approval step.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Go to the Opportunities view,
- Open the Opportunity DEF (DEF represents the Opportunity ID).
- Select the Actions button.
- Select Set to Won.
- The status can be Set to Lost or Won without Opportunity Approval.
Cause
Currently the system allows you to change the Opportunity status, regardless of whether the Approval is mandatory or not. Opportunities are internal document and different from Sales Quote as nothing is send out to customers afterwards. Therefore the behaviour is different.
Resolution
To implement this behaviour is a new feature request. Please post your idea on the Customer Influence Site; https://influence.sap.com/sap/ino/#/campaign/903
Alternatively, this could be achieved via PDI implementation. Please contact you partner in relation to this requirement.
Keywords
KBA , opportunity , approval , set to won , mandatory , LOD-CRM-OPP , Opportunity Management , Problem