Symptom
Welcome SMS trigger has been configured in the instance along with "Email trigger", but when a candidate creates an account in the career site , the email gets trigged to the candidate , however the sms does not gets triggered.
Environment
SAP SuccessFactors Recruiting Management (RCM)
Reproducing the Issue
- Go-to any career-site of customer instance.
- Go-to any open jobs posted, and click on apply.
- Go-to "Create Account" and fill all the details including mobile number.
- The SMS configured in "Welcome Candidate" notification does not send any SMS to candidate.
Cause
This is expected behavior.
Resolution
BizX cannot trigger any SMS to the candidate unless there is an explicit acceptance by the candidate that he/she is okay to receive the SMS.
Reason : BizX should not be sending SMS to candidate unless candidate himself opts-in to start receiving SMS notifications.
This acceptance from candidate is currently captured from the Candidate Profile only, which can be done after the account has been created.
Keywords
SMS, RCM, Candidate , KBA , LOD-SF-RCM-POR , Career and Agency Portals , Problem