Symptom
You have created the Workflow Rule ABC (ABC represents the Workflow Rule ID) that triggers notifications due some condition. The Workflow Rule is creating notifications successfully, but the log of the notification that has been triggered is not generated.
Environment
SAP Cloud for Customer
Reproducing the Issue
We will use a Task as example in this case.
- Go to the Activities work center.
- Go to the Tasks view.
- Open the task XYZ (XYZ represents the Task ID).
- Go to the Workflow Changes facet.
- There is not any log for the workflow rule ABC.
Cause
For Workflow Rules of type Notifications no workflow logs will be available and log functionality is only for rule of type: Email, Field Update, Messaging and Action. This feature of which rule was evaluated (as seen in the log) is not yet made available for both Cloud for Customer and Business by Design. In Cloud for Customer, most rule types other than "Notification" has this workflow log enabled and hence the user will be able to see the log details.
Resolution
This is the expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Workflow Rule, Notification, Logs, Workflow Logs , KBA , LOD-CRM-WKF , Workflow , How To