Symptom
You have created the Workflow Rule ABC (ABC represents the Workflow Rule ID) that triggers notifications due some condition. The Workflow Rule is creating notifications successfully, but the log of the notification that has been triggered is not generated.
Environment
SAP Cloud for Customer
Reproducing the Issue
We will use a Task as example in this case.
- Go to the Activities work center.
- Go to the Tasks view.
- Open the task XYZ (XYZ represents the Task ID).
- Go to the Workflow Changes facet.
- There is not any log for the workflow rule ABC.
Cause
For Workflow Rules of type Notifications no workflow logs will be available and log functionality is only for rule of type : Email, Field Update, Messaging and Action. This feature of which rule was evaluated (as seen in the log) is not yet made available for both Cloud for Customer and Business by Design. In Cloud for Customer, most rule types other than "Notification" have this workflow log enabled and hence the user will be able to see the log details.
Resolution
This is the expected system behavior.
If you need to have the workflow logs to Workflow Rule of type Notification available, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer.
Keywords
Workflow Rule, Notification, Logs, Workflow Logs , KBA , LOD-CRM-WKF , Workflow , How To