Symptom
When entering a Serial ID XYZ (XYZ represents the number of the Serial ID) in the ticket, the value help does not return the uniquely selected product record and the error message is displayed: "Serial ID XYZ is not unique. Please enter a Product.".
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Go to the Tickets view.
- Click New.
- In the Serial ID field, select the Serial ID XYZ.
Error message "Serial ID XYZ not unique. Please enter a Product." is displayed.
Note: the same applies to adding serial ID from the Products facet in an existing ticket.
Cause
When creating a ticket, system validates if the Serial ID is unique or not. In case there is a duplicate Serial ID, confirmation of the Product ID is needed.
Resolution
Please add the Product ID before the Serial ID.
- Go to the Service work center.
- Go to the Tickets view.
- Click New.
- Enter the Product ABC in the Product field (ABC represents the Product with the Serial ID XYZ).
- Enter the Serial ID XYZ in the Serial ID field.
See Also
2740929 - Error Message When Trying to Add a Registered Product to a Contract: Serial ID XXX not unique. Please enter a Product.
Keywords
Serial ID; Unique; Product ID; Ticket; Creation; QC; Error; Not Unique; Product , KBA , LOD-CRM-SRP , Service Request Processing , LOD-LE-IBA , Installed Base Data Management , Problem